PassFort Reports Disruption
Incident Report for Passfort
Resolved
This incident has been resolved.
Posted May 18, 2022 - 14:34 BST
Investigating
We are currently experiencing a disruption to our reporting service.

Our engineering team is working to identify the root cause and implement a solution.
Posted May 18, 2022 - 10:16 BST
This incident affected: PassFort Environments (🇪🇺 EU - identity.passfort.com).