Creditsafe | New issue regarding Italia/Italy | CSIT Director Searches
Incident Report for PassFort
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 10:07 GMT
Investigating
Creditsafe have given us the following message:
Dear Customer,

We want to apologise for the technical difficulties you may have experienced today when using the CSIT Director Search. We’re pleased to confirm that these issues have now been resolved.

We know that our customers work under tight deadlines and interruptions like this can be disruptive.

At Creditsafe we take great pride in our system availability and, while the cause of this outage was unanticipated, we will be reviewing our procedures and system architecture and will implement changes to minimise future disruption.

On behalf of the Creditsafe team, we would like to apologise for any inconvenience this has caused. We value and appreciate your business and will continue to work to support your business with high quality products and services and equally high availability.

Kind Regards
The Creditsafe Team
Posted Mar 24, 2022 - 09:37 GMT
This incident affected: Integration Hub (Creditsafe Company Data API).