Creditsafe Live Monitoring Downtime
Incident Report for Passfort
Resolved
This incident has been resolved.
Posted Mar 08, 2022 - 11:08 GMT
Investigating
Creditsafe have sent us the following message:

Dear Customer,

We are sorry to inform you that our Live Monitoring service is currently experiencing some technical difficulties. Our IT team are already working to resolve the issue as soon as possible.

We will keep you updated with progress via our status page and let you know as soon as we have resolved the difficulties, so there’s no need to contact us via telephone or email unless your case is urgent.

We apologise sincerely for any inconvenience this has caused.

Kind Regards
The Creditsafe Team
Posted Mar 08, 2022 - 10:22 GMT
This incident affected: Integration Hub (Creditsafe Company Data API).