Data provider RDC (GRID) - Elevated Error Rate
Incident Report for Passfort
Resolved
The incident has been resolved.
Posted Sep 14, 2022 - 07:59 BST
Investigating
PassFort is experiencing a higher than normal number of errors on checks instructed with the RDC (GRID) data provider. This is impacting PEP & Sanction screening checks.

Our engineering team is currently working to identify the root cause.
Posted Sep 12, 2022 - 20:36 BST
This incident affected: PassFort Environments (🇪🇺 EU - identity.passfort.com) and Integration Hub (Moody’s Grid).