RDC Maintenance Overrun
Incident Report for PassFort
Resolved
The maintenance has been rescheduled. Please see https://status.rdc.com for more details.
Posted Jun 14, 2020 - 00:47 BST
Monitoring
RDC have communicated that their scheduled maintenance has overrun.

In the meantime, you can track updates at https://status.rdc.com
Posted Jun 13, 2020 - 17:00 BST
This incident affected: Integration Hub.