Creditsafe | New issue regarding UK & Ireland
Incident Report for PassFort
Resolved
We received an update regarding this issue from Creditsafe:

Dear Customer,

We want to apologise for the technical difficulties you may have experienced today when using AML Check, ID Check and Bank Match. We’re pleased to confirm that these issues have now been resolved.

We know that our customers work under tight deadlines and interruptions like this can be disruptive.

At Creditsafe we take great pride in our system availability and, while the cause of this outage was unanticipated, we will be reviewing our procedures and system architecture and will implement changes to minimise future disruption.

On behalf of the Creditsafe team, we would like to apologise for any inconvenience this has caused. We value and appreciate your business and will continue to work to support your business with high quality products and services and equally high availability.

Kind Regards

The Creditsafe Team
Posted Sep 27, 2022 - 12:55 BST
Investigating
We have the following message from Creditsafe:

Dear Customer,

We are sorry to inform you that AML Check, ID Check and Bank Match are currently experiencing some technical difficulties. Our IT team are already working to resolve the issue as soon as possible.

We will keep you updated with progress via our status page and let you know as soon as we have resolved the difficulties, so there’s no need to contact us via telephone or email unless your case is urgent.

We apologise sincerely for any inconvenience this has caused.

Kind Regards

The Creditsafe Team
Posted Sep 27, 2022 - 11:31 BST
This incident affected: Integration Hub (Creditsafe Company Data API).