Creditsafe - Live monitoring Service unavailable
Incident Report for Passfort
Resolved
Creditsafe issue resolved

Message from Creditsafe -

Dear Customer,

We want to apologise for the technical difficulties you may have experienced today when using ID Check. We’re pleased to confirm that these issues have now been resolved.

We know that our customers work under tight deadlines and interruptions like this can be disruptive.

At Creditsafe we take great pride in our system availability and, while the cause of this outage was unanticipated, we will be reviewing our procedures and system architecture and will implement changes to minimise future disruption.

On behalf of the Creditsafe team, we would like to apologise for any inconvenience this has caused. We value and appreciate your business and will continue to work to support your business with high quality products and services and equally high availability.

Kind Regards
The Creditsafe Team
Posted Jul 27, 2022 - 11:02 BST
Investigating
We have received the below message from the Creditsafe Team -

Dear Customer,
We are sorry to inform you that we are currently experiencing some technical difficulties with our Live Monitoring product. Our IT team are already working to resolve the issue as soon as possible.
We will keep you updated with progress via our status page and let you know as soon as we have resolved the difficulties, so there’s no need to contact us via telephone or email unless your case is urgent.
We apologies sincerely for any inconvenience this has caused.
Kind Regards
The Creditsafe Team
Posted Jul 27, 2022 - 09:56 BST