PassFort may be slow loading
Incident Report for Passfort
Resolved
This incident has been resolved.
Posted Apr 13, 2021 - 11:40 BST
Monitoring
We are seeing improvements in the delays and will continue monitoring to ensure the issue is resolved.
Posted Apr 12, 2021 - 18:23 BST
Investigating
PassFort is currently experiencing a higher than normal amount of load, and this may cause pages to be slower than normal.

We're investigating the cause and will provide an update as soon as possible.
Posted Apr 12, 2021 - 15:52 BST
This incident affected: PassFort Environments (🇪🇺 EU - identity.passfort.com).