UAE portal and API errors
Incident Report for Passfort
Postmortem

Summary

On Thursday 25th May at around 06:13 BST, we received an alert that some requests to the PassFort platform were failing. After completing an investigation and remediation work, full service was restored around 09:00 BST.

Analysis

During the incident, some requests to recently deployed resources in the PassFort platform were unsuccessful due to internal network instability. Requests to less-recently deployed resources were successful.

This internal network instability was itself caused by a subset of overnight batch processing jobs being incorrectly scheduled to hardware reserved for live traffic.

Remediation

  • The configuration of the overnight batch jobs has been updated to better isolate them from adjacent resources
  • We have re-prioritised a project to replace the currently deployed network technology
Posted Jun 02, 2023 - 17:11 BST

Resolved
All service is restored and PassFort is operating normally.
Posted May 25, 2023 - 09:44 BST
Monitoring
The error rate has recovered and we are continuing to monitor the system
Posted May 25, 2023 - 08:50 BST
Update
We are continuing to investigate the issue.
Posted May 25, 2023 - 08:16 BST
Update
We are continuing to investigate
Posted May 25, 2023 - 07:33 BST
Investigating
We are currently investigating this issue.
Posted May 25, 2023 - 06:14 BST
This incident affected: PassFort Environments (🇦🇪 UAE - identity.uae.passfort.com).