Zendesk performance issue impacting support response times
Incident Report for Passfort
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 17:41 BST
Identified
Zendesk, PassFort's support tool provider is currently experiencing performance issues with is impacting our ability to respond to tickets.

Chat is unavailable and email support will be delayed while the issue is resolved.
Posted Jul 28, 2020 - 16:37 BST