Worldcheck checks in the EU may be taking longer than normal to complete.
Incident Report for Passfort
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 14:54 GMT
Monitoring
Some Worldcheck checks in the EU may be taking longer than normal to complete. We are monitoring the situation.
Posted Feb 19, 2024 - 11:37 GMT
This incident affected: PassFort Environments (🇪🇺 EU - identity.passfort.com).