Passfort intermittent disruption with PDF Audit Reports
Incident Report for Passfort
Postmortem

Summary

On July 18th at approximately 15:42 BST, our alerting systems flagged an unusual spike in API errors concerning the audit PDF generation feature of our product. These errors impacted multiple customers across all environments.

Analysis

An investigation revealed that the increase in errors was due to authentication issues within the internal systems responsible for PDF generation. This was traced back to a regression in the library used to automate the process. We found that the library version was not properly pinned, which allowed independent deployments of our internal systems to potentially alter the library version.

Action

The engineering team has locked the version of the specified library and resolved the authentication issues. These measures will prevent any future regressions caused by unwanted changes to the library used for generating Audit PDFs.

Posted Aug 27, 2024 - 16:41 BST

Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 11:23 BST
Update
We are continuing to investigate this issue.
Posted Jul 23, 2024 - 09:40 BST
Update
We are continuing to investigate this issue.
Posted Jul 22, 2024 - 17:47 BST
Update
We are continuing to investigate this issue.
Posted Jul 22, 2024 - 15:29 BST
Investigating
We are currently experiencing intermittent disruption to generating PDF Audit Reports.

Our engineering team is working to identify the root cause and implement a solution.
Posted Jul 19, 2024 - 13:57 BST
This incident affected: Passfort Environments (🇪🇺 EU - identity.passfort.com).