Creditsafe | New issue regarding Belgium and 12 others| Company Reports Downtime
Incident Report for PassFort
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 17:17 BST
Investigating
We have received the following message from Creditsafe:

Dear Customer,

We are sorry to inform you that Company Reports in the countries listed below are currently experiencing some technical difficulties. Our IT team are already working to resolve the issue as soon as possible.

Bosnia and Herzegovina, Bulgaria, Croatia, Czech Republic, Estonia, Hungary (Web), Kosovo, Latvia, Macedonia, The Former Yugoslav Republic Of North, Montenegro, Poland (Web), Romania, Serbia, Slovakia, Slovenia, Ukraine.

We will keep you updated with progress via our status page and let you know as soon as we have resolved the difficulties, so there’s no need to contact us via telephone or email unless your case is urgent.

We apologise sincerely for any inconvenience this has caused.

Kind Regards

The Creditsafe Team
Posted Jul 28, 2022 - 16:24 BST
This incident affected: Integration Hub (Creditsafe Company Data API).