Issue with our upstream provider
Incident Report for Passfort
Postmortem

Summary

All times are in UTC.

At 16:27 14-11-2023, a customer reported that they were unable to complete multiple actions in Identity. These included assigning cases, uploading files, tasks reverting to incomplete and changes not being saved. They were also receiving 5xx API responses from Passfort.

An investigation began immediately, and it was determined that the cause was an outage in an upstream software provider used by Passfort.

The Passfort status page was updated at 17:24 with the identified issue, and we continued to monitor the status page of the affected provider. The issue was resolved at 17:49.

Actions

  1. We are improving the way that we monitor outages in the third party providers that we use.
  2. We are looking into ways to increase the fault-tolerance of our services when these types of outages occur.
Posted Nov 23, 2023 - 10:33 GMT

Resolved
Our upstream provider, Pusher, has reported that service has now been restored.
Posted Nov 14, 2023 - 17:49 GMT
Identified
Our upstream provider, Pusher, is currently experiencing an issue which is affecting our ability to trigger notifications and updates, causing various failures. For further details, see https://status.pusher.com/.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Nov 14, 2023 - 17:24 GMT
This incident affected: PassFort Environments (🇪🇺 EU - identity.passfort.com, 🇦🇪 UAE - identity.uae.passfort.com, 🇺🇸 USA - identity.us.passfort.com).