Delays in email processing
Incident Report for PassFort
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 20:38 BST
Investigating
We have identified delays in email sending, which we are actively investigating.

Our engineering team is currently working to identify the root cause
Posted Apr 29, 2021 - 18:39 BST
This incident affected: Portal.