CreditSafe - Germany Shareholder Reports Downtime
Incident Report for Passfort
Resolved
CreditSafe have advised this issue has now been resolved. Please see below:

Dear Customer,

We are pleased to announce that the technical difficulties affecting the Germany Shareholder Reports have been successfully resolved. Users/Customers should now be able to access the Shareholder Reports for Germany without encountering any issues.

We know that our customers work under tight deadlines and interruptions like this can be disruptive.

At Creditsafe we take great pride in our system availability and, while the cause of this outage was unanticipated, we will be reviewing our procedures and system architecture and will implement changes to minimize future disruption.

On behalf of the Creditsafe team, we would like to apologize for any inconvenience this has caused. We value and appreciate your business and will continue to work to support your business with high quality products and services and equally high availability.

Kind Regards

The Creditsafe Team
Posted Mar 04, 2024 - 10:12 GMT
Investigating
We received the following notification from CreditSafe on 1st March 2024 at 17:28 GMT:

Dear Customer,

We are sorry to inform you that our Germany Shareholder Reports are currently experiencing some technical difficulties. Our IT team are already working to resolve the issue as soon as possible.

We will keep you updated with progress via our status page and let you know as soon as we have resolved the difficulties, so there’s no need to contact us via telephone or email unless your case is urgent.

We apologise sincerely for any inconvenience this has caused.

Kind Regards

The Creditsafe Team
Posted Mar 04, 2024 - 09:12 GMT